The Artima Developer Community
Sponsored Link

Agile Buzz Forum
Configuring SSH to Disable Host Key Checking

0 replies on 1 page.

Welcome Guest
  Sign In

Go back to the topic listing  Back to Topic List Click to reply to this topic  Reply to this Topic Click to search messages in this forum  Search Forum Click for a threaded view of the topic  Threaded View   
Previous Topic   Next Topic
Flat View: This topic has 0 replies on 1 page
Thomas Wheeler

Posts: 24
Nickname: twheeler
Registered: Jan, 2013

Thomas Wheeler is a Senior Consultant for Improving Enterprises, based in Dallas TX.
Configuring SSH to Disable Host Key Checking Posted: Jan 28, 2013 7:37 AM
Reply to this message Reply

This post originated from an RSS feed registered with Agile Buzz by Thomas Wheeler.
Original Post: Configuring SSH to Disable Host Key Checking
Feed Title: Random Artifacts
Feed URL: http://randomartifacts.blogspot.com/feeds/posts/default
Feed Description: Generally about agile, software development, and technical tips with occasional forays into other subjects.
Latest Agile Buzz Posts
Latest Agile Buzz Posts by Thomas Wheeler
Latest Posts From Random Artifacts

Advertisement
I often use scp to copy files between Linux/Windows systems, and ssh to remotely log in. In our work environment, we frequently redeploy new virtual machine ISOs. This causes scp and ssh to complain because the host's key has changed. Following the steps at I found at Linux Commando, here is how to configure SSH to disable the standard check for keys. NOTE: This can prevent SSH from detecting a real man-in-the-middle attack, so use with caution. I have configured this to only work with internal IP's. There are two ways to do this. The once-only way is from the command line:
$ ssh -o UserKnownHostsFile=/dev/null -o StrictHostKeyChecking=no

This tells ssh to use /dev/null for the known_hosts file, and to not use strict host key checking. For a more permanent way, put the following into the beginning of your ~/.ssh/config:
Host 192.168.*

StrictHostKeyChecking no

UserKnownHostsFile=/dev/null

(In my case 192.168.* refers to the internal network. Your environment may be different.)

This works on both Linux and Cygwin.

Read: Configuring SSH to Disable Host Key Checking

Topic: Mechwarrior 2: Mercenaries Previous Topic   Next Topic Topic: Good Design and Software Construction


Sponsored Links



Google
  Web Artima.com   

Copyright © 1996-2014 Artima, Inc. All Rights Reserved. - Privacy Policy - Terms of Use - Advertise with Us