Posted by Jim Morgan on January 28, 2000 at 11:36 AM
Enjoyed the article and wanted to send you a note to let you know I like the proposed changes. One downside is that the small device will need to do a bit more hunting and pecking to find the necessary service. The cost will be in time and network hits but at the gain of not having to load so many unnecessary classes.
Also noticed a few typos in the article which might detract from the help it provides. In both instances, you define the return from lookup as an array of ServiceMatches. For the two-parameter form this should just be ServiceMatches and the one-parameter form should just be Object. I think this also propagated into your two proposed methods. The method getServiceIDs should return ServiceIDMatches rather than ServiceIDMatches and getEntries should return EntryMatches rather than EntryMatches.