The Artima Developer Community
Sponsored Link

Legacy Java Answers Forum
December 2001



This page contains an archived post to the Java Answers Forum made prior to February 25, 2002. If you wish to participate in discussions, please visit the new Artima Forums.



Posted by Chris Mitchell on December 06, 2001 at 4:37 AM

> i don't think u can run jar files. a bit lazy to try it out, so before anybody else gives u the *totally* correct answer, probably i can try a "hit-and-miss" solution :p. better than nobody answering u yet rite? heheh

> what is your class file? i assume it's test.class since u put it in test.jar. is it in any package? if it's not, probably u can try something like this (assuming you're "cd"-ed to the directory where test.jar is in)

> run this command : java -cp G:\Data\Java_Dev\Generic_Classes\bytron.jar;test.jar test

I have solved the problem now. You are able to run jar files. To do this you have to add "Main-Class" to your manifest file.

I solved my problem by dropping the "G:" from the path of bytron.jar.

But thank you for you reply.

  • ah? Chin Loong December 06, 2001 at 5:34 AM (0)

Sponsored Links

Copyright © 1996-2009 Artima, Inc. All Rights Reserved. - Privacy Policy - Terms of Use - Advertise with Us