The Artima Developer Community
Sponsored Link

Legacy Java Answers Forum
September 2001



This page contains an archived post to the Java Answers Forum made prior to February 25, 2002. If you wish to participate in discussions, please visit the new Artima Forums.


Try checking the classpath

Posted by Suprakash Das on September 20, 2001 at 3:14 AM

Hi Alex,
If your class is within a package say somepackage, compile it like:
javac -d .
Try running the program with the complete qualified classname like:
java somepackage.makeFaxGUI

Hope this helps.

> Hello,

> I've always programmed for myself inside of my IDE, Kawa Pro - and have recently tried to run that same program outside of the IDE and all I get is - after succesful compilation:

> C:\makeFax>javac

> C:\makeFax>java makeFaxGUI
> Exception in thread "main" java.lang.NoClassDefFoundError: makeFaxGUI

> There is in fact a main class in makeFaxGUI - so I don't know what the problem is. If I run it from within KAWA Pro, it works just fine.

> Help appreciated!
> Alex


Sponsored Links

Copyright © 1996-2009 Artima, Inc. All Rights Reserved. - Privacy Policy - Terms of Use - Advertise with Us