I would suggest the name createUI() for the UIFactory interface instead of getUI(), as it describes better the purpose of a factory and is more standard for such purposes.
It might also be nice to require all UIs to fit a certain interface instead of relying entirely on the Entries to describe their purpose.
Also, should it be required that all Entries go into a package under org.jini.ui? Could they just be registered at runtime in some way instead? (Or maybe I'm just not familiar enough with the requirements. I'm not a Jini buff.)
Serviceui sounds good, though, based on the info in JavaWorld. I'm impressed. I like decent standards.